Consequences of Duplicate Addresses on a ModBus Plus Network

As with any addressable network, having duplicate addresses is an issue. On Modbus Plus networks, one of three things can occur. Modicon technical support disagrees on this subject but in my 30+ years of working with these networks all over the world, I have proven differently many, many times.

The first, and most likely event to occur,  the node that is being added to a network with the same address, will simply not be allowed to join the network.

The second thing that may occur, the node that is being added to the network will displace the existing node with the same address, assuming its’ place upon the network.

The third thing that may occur, is that when connecting the new node to the network with an existing node address is that the two nodes alternate joining and dropping off of the network.

The second and third options are obviously not desirable results. For this reason ALWAYS be certain of what addresses are existing on any given network. Utilizing a network discovery tool such as MBPStat, should eliminate any dual addressing.

Very recently, while performing a quick troubleshooting procedure upon a Modbus Plus network, I found a unique situation. I knew that I had a duplicate address on my computers’ PCMCIA card. however the plant was down, with no equipment running , and I was just doing a quick error check after repairing an illegal splice on the network. I was located at the MB+ repeater between segments 3 and 4 of this network. I monitored segment 3 for errors, all was OK, then I monitored segment 4 for errors, again all was OK. I reconnected the cables back to the repeater and then went to the end of segment 4 to monitor the entire network for errors. I was surprised to see all “U”‘s on every node! Those familiar with MBPStat, know that this indicates the monitor cannot properly identify the nodes. I went back to the repeater and checked both segments individually, again, all was OK. It was then that I remembered that I was utilizing an already assigned node address. I suspected this may be the issue. I again reconnected the cables back to the repeater, went to the end of segment 4,  reset the address to a non-assigned node address. Upon checking the network monitor, it now showed all nodes properly with no errors.This further illustrates the unusual results which may occur in the event of a dual node address.

This is even more reason to be aware of existing addresses when adding any nodes to a network!

Advertisements

About deltaautomation

President of Delta Automation, Inc. Working in industrial automation in excess of 30 years
This entry was posted in Delta company news, Delta service advantages, Modbus Plus, modicon, On-site stories, PLC, Service stories, Tech Tips, Uncategorized and tagged , , , , , , , , , . Bookmark the permalink.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s